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ISOPRO SOFTWARE DESCRIPTION

ISOPRO programs the Quick Circuit system to drill, mill and route your circuit board design. 

The number of computers on which ISOPRO can be installed depends on the license key 

you purchased. Only the computer connected to the controller will actually be initialized to 

run the milling table. 

The sample files used in this tutorial are on the installation diskettes on the CD. Your CAD 

files are translated into Gerber plot files for the CAM process. A general understanding of 

Computer Aided Manufacturing (CAM)  and Gerber files in particular is needed to use the 

IsoPro software. Refer to the Appendix A: Gerber and CAM essentials, and photoplotting 

principles for further detailed explanations. 

ISOPRO SOFTWARE INSTALLATION

The ISOPRO software is copy-protected with a hardware protection key that resides on the 

computer’s parallel or USB port. This software allows users to import the Gerber and Excel-

lon drill files and calculates the needed isolation or mill paths from the circuit board data.

To install the IsoPro software:

Step 1: Insert the IsoPro CD

Step 2: Follow the instructions in the Setup program.

	 Due to Windows security and variation in operating environments you may have to 

install for everyone in multi-user environments. This is the “anyone who uses the machine” 

option. In some cases computers with multiple Iso-Pro users will have to re-register the ma-

chine for the individual user. Please contact support for further help on this issue. 

   



Quick Circuit Prototyping Systems

�

ISOPRO SOFTWARE TUTORIAL

Overview

This tutorial provides a training procedure for using T-Tech’s IsoPro software. The sample case 
involves a typical design with a component side, a solder side and a drill file. This tutorial describes 
how to:

•	L oad your CAD data (importing Gerber of DXF files.)

•	G o to the layer list and ensure the bottom layer is identified as “solder”.

•	R egister the component and solder sides  
(for this tutorial the component and solder layers are purposefully input as Gerber files that 
do not register with each other)

•	 Correctly size the tools required by editing the Tool Table

•	P erform a clearance test

•	P erform a 0.25 mm (0.010“) and a 0.78 mm (0.031”) isolation  
(for use as a mill path to outline all of the pads and traces on the board)

•	P erform a 0.78 mm (0.031”) rubout that can also be used as a mill path to remove all excess 
copper

•	 Create a board outline

The hardware protection device [dongle] must be installed on the computer’s USB port in 
order to fully use IsoPro.

     



Quick Circuit Prototyping Systems Quick Circuit Prototyping Systems

�

Trace Cam Information 

If you purchased a TraceCam with your IsoPro software, please refer to the specifications 
below to  determine set-up and resolution and lighting control:

The source  tab provides options to control the lighting and brightness controls of the 
camera and enables the user to change these video options. 

The  format tab allows the user to control the resolution settings of the camera, T-
Tech recommends using the 320 x 240 resolution, however, the camera can be set at 
640 x 480.
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Importing Gerber Data Files

Step 1:	T o import your CAD design files, select File > Import from the tool bar.  We 
recommend that you use the Auto-detect File(s) feature to load your files. Click 
on Auto-detect File(s)... 

	

Step 2:     Select the folder that contains your files (in this case C:\IsoPro) Select the   
following files:

		2 74X.GBR		  component file 
		2 74X.SOL		  solder file 
		2 74X.NCD		  drill file

 
To import all three files at the same time, hold down the CTRL key and click on 
each file.		   
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change screen capture to show the 6 x 3 board that we will be using

You can identify the correct parameters by noting the file extents, which are 
approximately the same as the board size. 

Step 4:	 Double-click on the file extents that represent the approximate size of your 
board. For our purposes, select a board size of 5.9 x 2.99 inches using 4.3 
absolute mode and leading zero suppression.

When using your own CAD files, rather than the samples provided with this 
tutorial, select the file extents closest to the size of your circuit board data. 
Please note that file extents are approximate only. The Auto-detect File(s) 
feature does a quick estimate rather than an exact calculation of the board 
size.

Step 3:	 Click Open. The Auto Import window lists various parameters; including board 
dimensions (file extents), whole digits, precision digits and zero suppression 
methods.
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You may also bring in your file by using File > Open on the toolbar and 
specifying the import settings.

IsoPro also has an optional DXF import feature. If your IsoPro software is 
licensed for DXF import, click on File > Import > DXF File(s)... to import DXF 
data. 

A single DXF file often contains all the layers of a circuit board. IsoPro 
automatically imports each embedded layer separately. Use the Layer List 
(explained hereafter) to identify your layers as ‘Component’, ‘Solder’, or 
‘Drill’ as appropriate.

Layers containing unnecessary information, such as unwanted text, should 
simply be set to ‘Hide’.
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Working with Layers

IsoPro imports each file into a separate layer represented by a different color. Layers 
enable you to separate the component, solder, and drill information so that you can edit 
one without affecting the others. 

The Layer List icon looks like a stack of four sheets of colored paper. When clicked, it 
brings up the Layer Table. From here, you can change the layer color, name, status, and 
type. You can also specify whether the layer is mirrored and define the aperture table 
to use.

Layer Palette in the left margin of the screen displays the same colors as the ones 
shown in the Layer Table. This is an easy way to identify data on your screen. Changing 
a layer color in the Layer Table also changes it in the Layer Palette.

Set the following layer types for the tutorial files imported earlier:

			       set 274X.gbr to Component

			       set 274X.sol to Solder

Notice that 274X.ncd is already identified as Drill and that the layer type defined as 
Solder is automatically marked as ‘Mirror’.
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Mirroring here refers only to the files that are output for use with the Quick Circuit machine. 
On the screen in IsoPro, all layers are displayed as viewed from the component side of 
the board. When a layer is mirrored, it means that all future work on the particular layer 
will also be mirrored automatically.

There are three possible status modes. They are:

View -	A llows you to see the layer, but not edit the data. This is helpful 
when using a layer as a logical reference.

Edit -	A llows you to modify, select, delete, mirror, and edit t he data on the 
layer.

Hide - 	A llows you to hide the layer to prevent confusion while working on 
other layers.

While in the Layer Table, you can also add a new layer, copy an existing layer, or delete 
unnecessary layers.

Layer Registration

Purpose:	T o align the layers so that they line up (register) with one another.

For this tutorial, we purposefully created a component and solder side that did not line 
up with each other.

Inspect your CAD files to determine if the solder side is mirrored. If your solder side is 
not mirrored, the holes on each layer will NOT line up.

In the following procedure, you will first hide your drill layer since you will not be working 
with it for now. Then you will set the status for the component layer to View and verify 
that the status of the solder side layer is set to Edit.

Use the following steps to register each layer:

Step 1:	S et the 274.ncd layer to Hide. It is already registered so there is no need to 
display it at this time.

Step 2:	W e will be moving the solder data to register with the component data so set 
the component layer 274x.gbr to View so we do not change it.

Step 3:	S et the 274x.sol layer to Edit and make sure the Mirror check box is selected. 
The only data that can now be edited is the solder layer.

Note:  You can also change the status of the layers (i.e. Edit, View, Hide) by 
left clicking on that layer in the Layer Palette.

Step 4:	 Close the Layer Table.

Step 5:	U se your mouse to click and drag a box around the entire solder file (you can also 
use Edit > Select All or press Ctrl+A).
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Step 6:	T he next step is to mirror the board. Click on the Mirror icon. 

Step 7:	 Click on the Layer Registration icon to select the Register tool. 
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Step 8:	 Visually identify a pad on the solder layer and the component layer that should 
be registered with each other. Move the cursor over the pad on the solder 
layer and click the left mouse button.

While holding the button down, drag the cursor over the matching 
component pad. You will notice that the line snaps to the center of the 
pads. Once the line snaps to the correct pad on the component layer, 
release the mouse button. The data is then offset to the new position.

If you make a mistake, you can use the Undo function to undo the previous 
action and Redo to redo a previous action. IsoPro has unlimited Undo and Redo 
functionality.

Step 9:	O nce you have the layers registered, you can use the Layer List or Layer 
Palette to set the status of each layer to Edit.

In this tutorial the drill layer was already registered with the component side. 
However, if the drill file was not registered you would repeat this procedure 
for the drill layer.

Saving Your Work

At this point you should save your work. IsoPro files are saved as *.iso files. Select File 
> Save As in the menu bar and name the file “Tutorial Step1.iso”. This will allow you to 
come back to this step in the tutorial if you wish to practice.

A *.iso file includes all work done in IsoPro, including layers, aperture lists and tool 
tables. Work saved in a *.iso file may be restored at any time by selecting File > Open 
in the menu bar.
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Verifying the Aperture List

Purpose:	T o verify the aperture shapes and sizes used to draw your circuit board’s 
pads and traces.

To view the aperture list, click the Aperture List icon on your tool bar.  You should verify 
that your aperture list is correct for your circuit board.

In this tutorial, the imported files use the RS274-x standard. This means that all the 
apertures were imported directly without intervention from the user. T-TECH STRONGLY 
RECOMMENDS USING RS274-X FORMAT. Most CAD packages released since 1995 
support this format.

If your files do not use RS274-X, and you do not have an aperture list loaded, you will 
notice that your aperture dimensions default to 9.99 and 49.99. This is a very distinctive 
size and will probably never be used on a circuit board. If you see these values in your 
list, manually edit the aperture widths to match the output of your CAD package. Most 
CAD packages, when not using RS274-X, output the aperture list as a separate report 
file.
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Editing the Tool Table

Purpose:       To verify the tool sizes used to make your circuit board.

Click on the Tool Table icon on the tool bar.  The tool table usually imports into IsoPro 
automatically, but on occasion it may not. In that case you must edit the data manually.

  

change these screen captures to show current tool table information

If your tool sizes default to 49.99 mils or 1.27 mm, this is a flag that indicates these are 
the default values. For this tutorial, simply set Tool 1 to 0.78 mm (31.00 mils) and Tool 2 
to 1 mm (40.00 mils). Notice how IsoPro automatically selects the appropriate RPM and 
Mill Speed for the selected tool.

However, for your own applications, you should always match the sizes of the holes in 
your board to those that your CAD package outputs. These sizes can be determined 
by either looking at a report file that was output by your CAD package or looking at the 
header of the drill file itself. If they are in the header of the drill file, you can view it by 
opening the file using a simple text editor.
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Changing a Board Entity
At times, it may be necessary to manually change the size of an entity in IsoPro. Notice 
how the default entity size of 49.99 mils in this tutorial makes the drill hole oversized. To 
change the entity, follow the steps below.

		        

Step 1:	P lace the mouse over the entity to be changed and right click. This will reveal 
a drop down box. Select Properties. If using the same file, make the drill layer 
visible. 

Step 2:	T he Entity Properties dialog box appears.

‘D’ codes refer to the entities such as pads and traces, ‘T’ codes refer to 
the tool sizes.

In this example we are going to change the ‘T’ code (tool size). When a drill 
hole is centered on a pad, the entity [pad] will be shown first, and the drill 
size follows. Select OK until you reach the tool size window you want.



Quick Circuit Prototyping Systems

18

In some cases there will be two entities buried on top of each other. In this 
case, IsoPro will iterate through both entities. Changing the properties of 
an entity in this manner will not be necessary if the files from your CAD 
package are correct. (However, if you want to do some last minute editing 
without going back to your CAD package you can change the size or shape 
of a single pad or trace using this method. No other pads or traces will be 
affected.)

Step 3:	 Change the diameter of this hole from 49.99 mils to 0.78 mm (31.00 mils) as 
shown above, and then select OK. The resulting change in the drill hole is 
shown below.

Step 4:	R epeat these steps for each entity you wish to change.

Always remember to change your CAD file accordingly. Otherwise, your 
prototype board will be correct, but your production boards may not.
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Isolating the Layers

Purpose:	T o create an outline around the pads and traces of your design so that a 
circuit board prototyping system can produce your board.

Now that you have verified that your aperture list and files are correct, you need to 
isolate the component and solder layers.

Step 1:	S et the status of the drill and solder layers to Hide.

This is not a required step. However, it can help prevent mistakes and 
makes your first few board designs run a little smoother. 

Another way is to set the solder and drill layers to View. The important 
thing is to make sure that only the layer you wish to have in action is in Edit  
mode.

Step 2:	 Determine the minimum clearances for pad-to-pad, pad-to-trace, and trace-
to-trace distances. 

The initial isolation cannot exceed the minimum clearance. You can 
determine the minimum clearances in your circuit in IsoPro manually 
using the measure function or by using the Clearance Check function. 
Alternatively, you may already know this from your CAD software.

a)	 To determine the minimum clearance, select Tools > Clearance Check in 
the menu bar.

b)	 At the Clearance Check screen, click on Test. IsoPro will automatically 
determine the minimum clearance on that layer. Areas on the circuit that 
fail the clearance test will be highlighted. Make sure that the highlighted 
areas are de-selected before continuing. 
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IsoPro calculated that the minimum clearance for the component layer at 
0.34 mm (13.5 mils).

For the purposes of this tutorial, we will do the initial isolation with a 
0.25 mm (10 mil) tool, followed by a 0.78 mm (31 mil) tool. It is necessary 
to perform an isolation with a tool size equal to or less than the minimum 
clearance so that all of the nets in your circuit are properly isolated. 

Choosing a diameter that is too large will result in the merging of nets on 
your board. To solder more easily, a larger second pass, in this case 0.78 mm 
(31 mils or 0.031”), is recommended.

This is typically all that is required for a digital board but please note that 
IsoPro can perform up to three different size isolations simultaneously.

Step 3:	 Click on Tools > Isolate in the menu bar.

Enter 0.25 mm (0.010”) for Pass 1 and 0.78 mm (0.031”) for Pass 2. Set 
Pass 3 to zero which indicates that this pass is not used. 

Note:  Tool sizes can be entered in inches or metric mode [mm]. Metric mode 
can be selected from Edit > Preferences in the menu bar.

Step 4:	S elect the component and solder layer by holding down the CRTL key while selecting 
both layers.

Step 5:	 Click on the Isolate button. 
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You will see different color representations (or shades of gray if you did not print this 
manual in color) of the defined mill paths for both the component and solder layers once 
the isolation process is completed. 

Notice that four additional layers are shown on the Layer Palette. Click on the Layer icon to see 
the definitions for these new layers.

When IsoPro creates the isolation layers, it automatically lists them by tool size. In addition, 
it defines all isolation layers for the solder layer as mirrored. (This occurs only if you selected 
Solder as the layer type.)

IsoPro also provides several special options for use during the isolation routine. These 
are Remove Redundant, Force Isolation and Expand Pads.

Remove Redundant Function

Remove Redundant locates and deletes those sections of the smaller tool isolations, which are 
completely overlapped by larger isolation paths. On some types of circuit boards, the use of 
Remove 
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Remove Redundant Function

Remove Redundant locates and deletes those sections of the smaller tool islations, which are 
completely overlapped by larger isolation paths. On some types of cicuit boards, the use of 
Remove Redundant can offer significant savings in machine time and tool wear. The Remove 
Redundant option is enabled and disabled in the the Isolation dialog box. 

In the illustration above, we are isolating only the component Layer by setting the solder layer 
to Hide and the drill layer to View. We are making two isolations and have enabled the Remove 
Redundant feature by checking the applicable box in the Isolation dialog.

	

Enabling the Remove Redundant option prevents isolations from occurring (as shown in the 
figure on the left). The red (or darker gray) represents the 0.25 mm (10 mil) isolation path. It 
only appears in those areas where the subsequent isolation, in this case the 0.78 mm (31 mil) 
represented by the light green (or lighter shade of gray), cannot effectively remove the required 
copper. Without the Remove Redundant feature, your isolation paths appear as shown in the 
figure on the right.
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Expand Pads Function
Expand Pads is used to increase the number of isolation passes around a pad without 
increasing the number of passes around associated traces. This feature is useful in 
widening the area around pads to provide additional space for soldering.

As shown above, isolate only the component layer by setting the solder layer to Hide and the 
drill layer to View. As before, we want to make two isolations and enable the Expand Pads 
feature on the second pass since it is the larger one. When Expand Pads is selected, you must 
also specify the number of additional passes you wish to make with that tool.

Looking at the illustration below, we can see that the second isolation paths around the 
pads are twice as wide as those around the traces.
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Merging Layers

Purpose:		T  o combine all like layers for seamless milling also allowing for the Auto Tool Change 
function to be used.  Without merging layers the machine will stop milling after each layer and ask 
for a new tool.
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Inspecting the Isolations
It is a good idea to zoom in and inspect the isolation to make sure it was done properly. 
You should see a clean outline around each electrical net.

Use the zoom-in  cursor on the tool bar to drag a window around an area of interest.

Use the pan-hand feature to move around and inspect the data.  

If the isolation path is not completely defined around each entity on your board, or if 
the isolation path is too large as a result of using the Force Isolation feature, the board 
will not be electrically correct. Use a smaller tool size and repeat the Layer Isolation 
procedure as needed.

Rubbing Out the Base Copper

The Rubout feature allows you to remove an area of unwanted copper in a single function. 
Ordinarily, you would not perform a rubout on a digital board; however, if you have a set 
of fingers (for an edge connector) or an SMT component that requires a rubout, you can 
take off copper from a particular part of the board, several specific areas of the board or 
the entire board. The Rubout feature can be useful for many RF/MW applications.

You can also modify the rubout area by using the “Ball & Stick” mode under View in the 
menu bar, then selecting unwanted portions of the rubbed out area and deleting them. 
The “Ball and Stick” view mode allows you to see the exact path of the rubout tool.

Rubout only works one layer at a time. If you want to perform a rubout on both the 
component and solder layers, you must repeat this procedure for each side.

Step 1:	S et the isolation layers where you want to create a rub out to Edit .The Rubout 
function will automatically select the largest size isolation layer available in 
Edit mode and base the Rubout pattern on this tool size.

Step 2:	 Click the Rubout icon at the bottom of the right vertical tool bar. 

Step 3:	 Drag a box around the area(s), where you want to rub out the base copper. 
Release the mouse to activate the Rubout.
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Yellow (or light gray) areas show the effect of a partial Rubout as shown above, or of a 
full Rubout as shown below.
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Creating the Board Outline

Purpose:	T o create an outline of your board.

You can import the board outline from your CAD package or create it in IsoPro. Using 
IsoPro, there are two methods for creating the board outline:

•	 Click on the Create New Rectangle icon on the lower left of the screen , and 
drag and draw a rectangle for the board outline

•	 or lay out individual lines around your circuit if a simple rectangle is not appropriate

In either case, start by creating a new layer to put information about the board outline.

Step 1:	 Click on the Layer icon and select  New. 

Step 2:	S et the component layer to View and all the other layers to Hide except for 
the new layer which should be in Edit  mode.

Step 3:	N ame the new layer Board Outline, then close the dialog window.

Step 4:	T he most common routing tool is the 1.575 mm (62 mil) diameter router. At 
the bottom of the screen, define the tool shape as Round and its Width as 
62 mils (1.575 mm if you are in metric mode).

If you are using a different tool size to create your board outline, enter the 
appropriate information in the Shape and Width boxes.

Step 5:	F or the purpose of this tutorial, we want to use a simple rectangle as the 
outline for our board.

Click on the box shaped icon and bring your cursor to the upper left area of 
your circuit. Click and drag a box around your circuit. When done, release 
the mouse.

You can resize the outline as needed, until you are satisfied with the result.

Alternately, if you have your board outline described on a Gerber layer:
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Step 6:	S et the layer that contains your outline data to Edit and other layers to View or 
Hide.

Step 7:	 Delete all traces, pads and text that are not part of the outline.

Step 8:	S elect all of the traces that form the outline.

Step 9:	F rom the Edit menu, select Convert to Polygon.

Step 10:	N ow, isolate this layer with a .062 mil tool (or the appropriate diameter for your 
board)

	

We recommend that you create the board outline before you perform the Rubout 
function. This way the board outline will serve as a boundary for creating a full rub 
out if needed.

Creating Text

Purpose:	T o create text on a board.

Creating text in IsoPro is very easy. IsoPro offers a wide variety of fonts and sizes. The first step 
is to create a new layer for the text to reside on. Follow the steps below:

Step 1:	 Click on the Layer icon and select  New. 

Step 2:	S et all the layers to View or Hide except for the new layer which should be in Edit  
mode.

Step 3:	N ame the new layer Text.

Step 4:	A t the bottom of the screen, click on the icon containing the letter A.
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Step 3:  Name the new layer Text									       
	

Step 4:	A t the bottom of the screen, click on the icon containing the letter A.

 

Step 5:	P lace your cursor where you want to locate your text. A dialog box will appear

Step 6:	T ype in “T-Tech” and select the text font and size as needed. When finished, 
select OK. The text image appears on the board.

Vector fonts are recommended for milling. These are fonts that are made 
of only center line data as opposed to TrueType fonts which are made of 
outlines.

True Type (TTF) fonts should be converted to a polygon to avoid milling an 
outline instead of a full letter.
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You are now done with your design that will be used by the Quick Circuit prototyping 
machine. Save this file as “Tutorial complete.iso”. If you design on a computer that does 
not have a Quick Circuit attached, save your .iso file to a disk or copy the file to the 
computer where your Quick Circuit is located.

Keep a copy of this file in a safe place. If you ever notice Quick Circuit created poor 
quality boards, having a known “good” file will help you discover if the problem is 
hardware or software related. See Diagnostics on page 67.
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“Mill” Drop Down Menu

The Mill drop down menu is probably the most used function in the menu bar. A brief 
description of each item associated with this menu is given below. 

Initialize / Re-Initialize – Prepares IsoPro to run Quick Circuit and zeroes the machine.

Setup > Adjust Pin Position – Adjusts the Y-position of the pin to improve hole-to-pad 
registration on double-sided boards. This is a fine adjustment used with the Set Pin 
Position feature.

Setup > Material – Sets chip load and surface speed.

Setup > Set Pin Position – Sets pin position with respect to the current head 
position. Use the Adjust Pin Position feature to fine-tune the head position. 

Run Layer – Allows user to select a layer to be machined.

Mill Selected – Machines the selected entities on a layer.

Pause – Temporarily stops operations to give the user control of the machine.

Stop – Stops operations on the milling table.

Tool Change – Brings the head assembly to the front of machine to allow for tool 
change.

Material Change – Sends the head assembly to the back of machine to allow for material 
change. The Material Change position is determined by the size of the board.
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Home – Returns the head assembly to Home position. (Home is specified under 
Preferences > Machine Settings in the menu bar.)

Head Down/Up – Raises or lowers the head assembly.

Jog – Places the machine under user control.

Move – Allows an absolute or relative move of the head assembly.

Spindle – Turns the spindle on or off. A checkmark next to this item indicates that the spindle 
is on.

Park – Returns the head assembly to the Park position. (The Park position is set under Preferences 
> Machine Settings in the menu bar. The head assembly travels to the designated Park position 
after completing a drill/mill routine.)

Zero Machine – Zeroes the milling table. 

Right-Click Menu

Right clicking in the main window and selecting the “Machine” cursor menu gives you the 
following display. 

Jump to Cursor – Moves the head assembly to the 
current X,Y position of the cursor.

Machine Net – After right clicking on an entity, the machine mills all entities contained in 
connected the net.

Test Depth of Cut – Allows you to test the depth of cut of a pointed milling tool. This feature is 
not available if the machine has not been initialized.

Mill to End – If you need to stop machining on a board before the entire layer is finished, this 
feature allows to specify a new starting point and select Mill to End to finish machining the 
layer entities.
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Manual configuration of IsoPro Machine Drive

When you install IsoPro using the CD/disks 

included with your machine, your machine configuration is set automatically. However, if you 
need to set or change some of these parameters, you can do so by selecting Edit > Preferences 
> Machine Settings tabs.

Machine Model – Allows you to select your machine type.  Select Quick Circuit/HF.

Comm Port – Allows you to specify which communications port the controller is connected 
to.

High Speed Spindle – Allows you to indicate whether or not you are using a high-speed spindle.  
This should be checked for the Quick Circuit/HF.

Feeds (inches per minute)

Milling Speed – Indicates the tool speed with the head assembly down during a 
manual move.

Traverse Speed – Indicates the speed at which a tool moves with the head 
assembly up.
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Bed Size (inches)

X- –  Indicates the usable bed space in front of the pinning hole. This area is 
used to prepare mill paths before machining.

X+ – Indicates the usable bed space behind the pinning hole.

Y- –  Indicates the usable bed space to the right of the pinning hole.

Y+ – Indicates the usable bed space to the left of the pinning hole.

Home Offset from Pin (inches) 
The Home position is usually set at X = 0, Y = 0.

X distance – Determines the location of the Home position on the X-axis as 
an offset value from pinning position.

Y distance – Determines the location of the Home position on the Y-axis as 
an offset value from pinning position.

Spindle Speed (RPM)

Min – Indicates the minimum actual speed to be associated with the 
minimum software speed. This value should be different depending on type 
of spindle.

Max – Indicates the maximum actual speed to be associated with the 
maximum software speed. This value should be different depending on type 
of spindle.

Park Position (inches) 
The Park position should outside the edges of the board. After each layer is machined, 
the head assembly moves to the Park position.

X location – Determines the location of the Park position on the X-axis as 
offset from the Home position.

Y location – Determines the location of the Park position on the Y-axis as an 
offset from the Home position

Z-Axis

The Z-Axis is controled by a stepper motor and adjusts Z+- steps as called for by 
the controller.
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Z-Axis Ramp Time (sec)

Milling – Indicates the time it takes to ramp the solenoid power from zero 
to full power while milling.  This feature is not used on the Quick Circuit/HF 
model.

Drilling – Indicates the time it takes to ramp the solenoid power from zero 
to full power while drilling. This feature is not used on the Quick Circuit/HF 
model.

Solenoid PWM Frequency – Base frequency that is used by the pulse width modulation 
of the solenoid. There should not be any reason for you to change this value.  This 
feature is not used on the Quick Circuit/HF model.

Z-Axis Delay (sec)

Separate Delay for Drilling and Milling operations.

Up – Indicates the amount of time to wait after a head up command before continuing 
with next command.  This feature is not used on the Quick Circuit/HF model. 

Down – Indicates the amount of time to wait after a head down command before 
continuing with next command.  This feature is not used on the Quick Circuit/HF 
model.

Z-Axis Ramp Time, Solenoid PWM Frequency and Z-Axis Delay should not  
be changed from their defaults unless you are experiencing problems with 
tools not penetrating your board material or dwelling too long in the board 
material.

Additional Features

There are many additional features built into the IsoPro program. You should take the 
time to become thoroughly familiar with all of the tasks, icons and commands. Please 
reference IsoPro’s extensive on line Help menu for additional information concerning 
IsoPro’s features.
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Appendix A                    

The following is reprinted with permission from an article in the November 1992 edition of 
Printed Circuit Design Magazine:

Gerber and CAM Essentials 

The inside view

   by Andy Wise

	T oday, virtually all PCB designs are reduced to a series of Gerber plot 
files as the first step in the PCB manufacturing process. These Gerber 
files constitute the database that drives the CAM process. Historically, 
designers have been unaware of the exact nature of Gerber files and 
were therefore unable to verify the correctness of a Gerber file or open 
a dialog with the CAM people about the problems that commonly occur. 
Furthermore, without having the proper tools, designers have had little 
or no control of their design once it has been committed to a Gerber 
database.

What is Gerber?

	G erber is the de facto standard photoplotting command language. 
It is supported by virtually all modern photoplotting equipment in use 
today. The command structure and format of a Gerber file (the name 
Gerber borrowed from the popular photoplotter maker Gerber Scientific 
Instruments Co.) is actually a subset of the EIA RS-274-D standard for 
numerically controlled machines. Each Gerber file contains commands 
and data that instruct the photoplotter on where to expose the film when 
generating PCB artwork.

Gerber Command Structure

	W hile typical Gerber files can be megabytes in size, there are only a few 
essential commands in the Gerber language. The most prevalent are the 
“G” and “D” command codes, commonly referred to as G-codes and D-
codes. The G-codes are called preparatory codes and are used to set the 
state of the plotter. The D-codes serve a dual role. They act as aperture 
select commands, or, along with XY coordinates, they specify whether the 
photoplotter “flashes” an aperture or “draws” a line.

	T he terms “flash” and “draw” relate to the older vector photoplotters 
that exposed the film through an aperture (Figure 1) by either momentarily 
energizing a light source while stationary (flash) or by maintaining 
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there is not a one-to-one relationship between aperture position numbers 
and D-codes! In other words, you can’t simply subtract nine from a D-
code to find its aperture position. The reason behind the madness stems 
from the use of aperture “wheels” on the old vector photoplotters. 

	F igure 1  Photoplotter operation

	T hese wheels typically contained 24 different apertures and for 
reasons unknown to this author, they were numbered as shown in Table 
1. Fortunately, the right CAM software will automatically handle the 
ordering of D-codes within an aperture list. Furthermore, a major benefit 
of modern laser photoplotters is the absence of an aperture wheel. There 
is no 24-aperture limit nor a need for a list mapping aperture positions 
to D-codes! Although an aperture list is still required, it simply needs to 
describe the size and shape of each D-code used.
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Table 1 
Aperture Wheel/D-Code Mapping

Aperture D-Code Aperture D-Code
1 D10 13 D20
2 D11 14 D21
3 D12 15 D22
4 D13 16 D23
5 D14 17 D24
6 D15 18 D25
7 D16 19 D26
8 D17 20 D27
9 D18 21 D28

10 D19 22 D29
11 D70 23 D72
12 D71 24 D73

An Incomplete Language

	A  major shortcoming of the Gerber command language has been the 
lack of a method to describe the size and shape of apertures within a 
Gerber file. Thus, a separate file in a nonspecific format is typically used 
to convey this information to the CAM operator. Because of this, much 
time and money has been wasted on bad film. Bad boards have been 
built if the errors are not detected in time, due to errors in converting 
aperture lists. Fortunately, the correct CAM software can recognize and 
automatically convert most aperture lists in use today. 

A Variable Format Language

	A lthough Gerber only has a handful of basic commands, the format 
of these commands can vary, adding confusion to the deciphering of 
Gerber data. Gerber files may be generated using imperial or metric units 
of measure. The precision of the data coordinates may be specified in 
different ways. For example, the value 01255 could be interpreted as 1.255 
if two places are assumed before the decimal point (2.3 format) or 12.55 if 
three places are assumed (3.2 format).

	 Coordinate data may also be specified in either absolute or incremental 
formats. In absolute format, all coordinates are relative to the photoplotter 
origin or 0,0 point. On the other hand, incremental format specifies each 
coordinate value relative to the previous coordinate. Coordinate data may 
also be specified with either leading or trailing zeros suppressed. Thus 
1255 could be interpreted as 1.255 or 12.550 assuming 2.3 precision. 
Again, the right CAM software should be able to automatically detect the 
format of a Gerber database (Figure 2).

G54D41* 
G01X00200Y00600D03* 
G54D20* 
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G01X00500Y00500D03*   
G01X00500Y00600D03* 
G01X00200Y00600D02*   
G54D12* 
G01X00350Y00600D01* 
G01X00350Y00500D01*   
G01X00500Y00500D01* 
G01X00200Y00500D02*   
G01X00275Y00500D01* 
G01X00275Y00400D01*   
G01X00500Y00400D01* 
G01X00200Y00300D02*   
G01X00500Y00300D01*   
M02*

	F igure 2  Sample Gerber file and plot.

What’s Missing?

	W hen a CAD system outputs the Gerber database, almost all of 
the electrical intelligence is lost. That is, all reference designators, pin 
numbers and, hence, netlist information is missing. The most serious 
consequence of this is the one-way nature of Gerber. There is no way to 
automatically back-annotate a design from changes made to the Gerber 
database. This isn’t to say that you can’t do anything useful with Gerber 
other than photoplotting. Quite the contrary!



Quick Circuit Prototyping Systems

40

Aperture Wheel Setup for Vector Plotters

	T he setup of an aperture wheel is an exacting and time consuming 
process since each aperture in the wheel must be hand-mounted and 
aligned. In order to avoid repeated setup costs, designers have the 
photoplotting vendor keep a wheel on file and are forced to always use 
that same set of apertures. This has obvious drawbacks, both in terms of 
design flexibility and the ease of migration to other vendors.

Raster (Laser) Plotters

Aperture Lists

	I ncreasingly, vector photoplotters are being replaced by the laser 
photoplotter, which emulates the older style machine in a raster (bit-map) 
fashion. While use of the term “aperture” to describe a pad or trace shape 
persists, the term “aperture wheel” is now being replaced by “aperture 
list”, which implies the greater flexibility now available to the designer.

	T here are three principle advantages with aperture lists on raster 
plotters:

Aperture shapes can be easily generated in software, thus eliminating the need to 
design a physical wheel.

More apertures can be defined on a list.

Allowable apertures sizes are typically (but not always) greater than those imposed 
by the physical dimensions of an aperture wheel.

Flash and Draw Apertures

	N o distinction need be made between Flash and Draw aperture types 
since the light source intensity is constant.

Speed Advantage of Laser Plotters

	L aser plotters operate much quicker than vector machines. A complex 
plot that required hours on a vector machine can usually be performed 
in ten minutes or less on a laser photoplotter. This decreases turnaround 
time and in many markets has driven photoplotting costs down.

Talking to Photoplotters

	T he de facto standard for photoplotter data is the Gerber format, 
more properly known as RS-274D. The term Gerber refers to the Gerber 
Scientific Instrument company, a pioneer and leader in photoplotter 
manufacturing.

	RS -274D is a variation on traditional Numerical Control (NC) machine 
tool languages. It differs from traditional NC formats (i.e. drill data), as far 
as its use of tool selection codes but is otherwise compatible.



Quick Circuit Prototyping Systems Quick Circuit Prototyping Systems

41

	RS -274D data is organized in “blocks”. A block consists of a 
combination of codes:

Tool selection 
Setup 
Movement 
And, an End Of Block (EOB) character, which only follows a combination of the 
above codes.

	A n EOB character is usually an asterisk (‘*’) or dollar (‘$’), optionally 
followed by a carriage return and line feed.

	A n RS-274D code consists of a letter D,G,M,X,Y,I or J followed by a 
numerical value. These codes designate the following:

		  * - End of Block (end of command)

		  D - Select aperture, or set aperture use mode

		  X - Move to X value

		  Y - Move to Y value

		G   - Various setup codes

		M   - Various control codes

		I   - Relative X location for arc center

		  J - Relative Y location for arc center

D Codes

	 D codes have multiple purposes. The first is to control the state of the 
light being on or off. Valid codes for light state are D01, D02, and D03.

		  D01 - Light on for next move.

		  D02 - Light off for next move.

		  D03 - Flash (Light On, Light Off ) after move (effect is limited to 
block in which appears, ie non-modal). You can also think  of a D03 as 
D02, D01, D02 series of commands linked together.

	 D codes with values of 10 or greater represent the aperture’s position 
on the list or wheel. It is very important to understand that there is no 
universal “D10” or “D30”. Unlike the D01 , D02, and D03 counterparts 
which have a fixed meaning (draw, move, flash), D10 and higher values 
have aperture shapes and dimensions assigned to them by each 
individual user. Hence, one job’s D10 could be a 10 mil Round, when 
another job’s D10 could be a 45 mil Square.

	T here are two distinct ways to number an aperture list. The traditional 
24 aperture system started with D10 - D19, jumping suddenly to D70 - 
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	T he X & Y values in the Gerber file determine where the aperture shape 
and dimension will be positioned and drawn. X & Y values are used as 
coordinate pairs to determine where the light will be exposed, using the D 
codes shapes (i.e. D10) and light exposure status (i.e. D01, D02, D03) for 
drawing lines and arcs, as well as moving between drawing entities.

	H ere are a few examples of using X & Y codes with D codes.

		  D10*  { Select aperture D10}

X1000Y1000D02* {The D02 tells us that the light will be off, and we 
move to coordinate position X1000 and Y1000}

X2000Y3000D01* {The D01 tells us that we will draw (light on) to 
coordinate position X2000 and Y3000}

X5500Y100D03* {The D03 tells us to move to coordinate position 
X5500 and Y100 with the light off, then flash (turn 
the light on and off )}

G Codes

	G  codes are used to configure the photoplotter. Commonly 
implemented codes include:

		G  01 - Future X,Y commands are straightline moves

		G  02 - Future X,Y commands are clockwise arcs

		G  03 - Future X,Y commands are counterclockwise arcs

		G  04 - Ignore the rest of this block (used for Comments)

		G  54 - Prepare to change apertures

		G  74 - Future arcs are quadrant arcs

		G  75 - Future arcs are Full 360 arcs

		G  90 - Absolute data

		G  91 - Incremental data

	T ypically for laser photoplotters, G54 codes are rarely necessary. 
Older vector plotter controllers may require this preparatory G codes for 
changing apertures (i.e. G54D10*).

	A  common situation where G codes are mandatory for all machines 
is when the data is switching from vectors to arcs and vice versa. When 
switching from drawing vectors (G01) to drawing arc (G02, G03), the 
controller must be informed of the change of mode.

	A nother important case for G codes is when determining if the arc is 
a quadrant (G74) or Full 360 (G75). Quadrant arcs never cross quadrant 
boundaries, because the center coordinate offsets (I,J Codes) are always 
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unsigned (even if they are negative!).

	T herefore, it requires at least four G74 arcs to draw one complete 
circle.

	 Center coordinate offsets for 360 arcs (G75) can be positive or 
negative, allowing for a single command to draw a complete circle.

	I n either case, the center coordinates are given relative to the start 
point of the arc. The most dramatic difference between Quadrant and Full 
360 arcs is that a Quadrant arc with identical start and end points has a 
sweep of 0 degrees, whereas a similar Full 360 arc is a full circle.

	T he G90 code tells the machine controller that all data following is 
absolute data. Hence, if following X & Y data follows, the controller will 
move to the absolute value given by the X & Y value.

	G 91 tells the machine controller that all data following is incremental 
data. The machine will move the data by the amount of the X & Y value, 
rather than to the absolute coordinate point.

	E xample:

		  X1000Y1000D02*

		  X3000Y3000D01*

	I n absolute mode (G90), the machine will first move to coordinate 
point X1000 and Y1000 with the light off, then draw a line to coordinate 
point X3000 and Y3000 with the light on.

	I n incremental mode (G91)  the machine will first move to coordinate 
point X1000 and Y1000 with the light off, then draw a line to coordinate 
point X4000 and Y4000 with the light on. This was done by adding X1000 
+ X3000 = X4000 and Y1000 + Y3000 = Y4000.
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                                    NOTES 
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